Project

General

Profile

Bug #1518

New source takes extremly long

Added by Stefan Eichert 5 months ago. Updated 5 months ago.

Status:
Closed
Priority:
Low
Category:
Backend
Target version:
Start date:
2021-05-20
Estimated time:
Found in version:

Description

Adding a new source in the thanados instance takes extremly long. (2min +). Tested on V.6.3.0. Testing the same locally, (v.6.2.0) works as supposed with the same database dump.
Tested on Chrome on various machines with fast internet.

History

#1

Updated by Alexander Watzinger 5 months ago

  • Found in version set to 6.3.0
  • Target version set to 6.3.0
  • Assignee set to Alexander Watzinger
  • Status changed from New to In Progress
  • Category set to Backend
  • Project changed from THANADOS to OpenAtlas

Can confirm, moved the issue to the OpenAtlas project and will look into it. Thank you for reporting.

#2

Updated by Alexander Watzinger 5 months ago

  • Status changed from In Progress to Closed

This was a rather strange one.
First I couldn't reproduce it locally, one difference to the online version was that I hadn't that many files in the upload directory. So I imported files from an old backup and with that I was able to reproduce the long loading times. Being able to reproduce it I found the culprit: using a render_template function for check boxes in multi select tables in forms. Doing this without templates made it much faster. The strange thing is that this should be completely unrelated to the amount of files in the upload directory, it also makes no differences after removing the template call anymore.

However, it still takes a few seconds but is much faster than before. The fix is in the develop branch which I already uploaded to THANADOS.
I hope entering of data goes smoother now and thanks again for reporting.

#3

Updated by Stefan Eichert 5 months ago

Thx for the quick fix!

Also available in: Atom PDF