Project

General

Profile

Bug #1474

Polyline/Area cannot be deleted

Added by Sonja Mayer about 2 months ago. Updated about 1 month ago.

Status:
Closed
Priority:
Low
Category:
Maps
Target version:
Start date:
2021-03-02
Estimated time:
Found in version:

Description

Concerns: https://thanados.openatlas.eu/entity/45097

Error:
The created "Area" has to be deleted 8 times before it is no longer visible. (Seems to be multiplied, because after each deletion the blue area becomes brighter.)
If the edit mode is left via "Save", the deleted lines are nevertheless visible again.(The polyline also reappears after deletion.)

Course of action:
"Polyline" was drawn and saved, suddenly it was no longer visible.
therefore an "Area" was selected and saved.

After leaving the edit mode suddenly both became visible again.

History

#1

Updated by Sonja Mayer about 2 months ago

  • Found in version set to 6.0.0
#2

Updated by Alexander Watzinger about 2 months ago

  • Target version set to 6.0.0
  • Assignee deleted (Alexander Watzinger)
  • Status changed from New to Acknowledged
  • Category set to Maps

I can confirm this bug in the development version, in fact I wasn't able to delete it at all. We have a meeting at the end of week with our frontend developer and will take a look at it.
Thank you very much for reporting and sorry for the inconvenience.

#3

Updated by Stefan Eichert about 2 months ago

I also worked on some other sites and it is no longer possible to delete point geometries either.

#4

Updated by Christoph Hoffmann about 2 months ago

  • Assignee set to Christoph Hoffmann
  • Status changed from Acknowledged to Assigned
#5

Updated by Alexander Watzinger about 2 months ago

  • Assignee changed from Christoph Hoffmann to Alexander Watzinger
  • Status changed from Assigned to Closed

We found the error and the fixed development version is already only at https://thanados.openatlas.eu. Everything should work again as expected, please inform us if not.

Thanks again for reporting.

#6

Updated by Alexander Watzinger about 2 months ago

  • Status changed from Closed to In Progress

Sorry but the site will be down shortly, we have to fix something on the server.

#7

Updated by Alexander Watzinger about 2 months ago

The site is up again. It may be that geometries saved since the bug was present (a few days ago) were saved multiple times. I tried to fix that too but caused too much server downtime so I may fix that in the weekend.
Sorry again for the inconvenience.

#8

Updated by Alexander Watzinger about 2 months ago

  • Status changed from In Progress to Closed
#9

Updated by Alexander Watzinger about 1 month ago

Today I looked at the geometries data in more detail and was able to delete all duplicate geometries which could have happened because of former bugs or imports. Now everything should work as expected and it shouldn't be necessary do delete geometries more than once. Please notify me in case you experience other irregularities and thanks again for reporting.

Also available in: Atom PDF